aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiguel Ángel Arruga Vivas <rosen644835@gmail.com>2020-10-24 14:35:09 +0200
committerMiguel Ángel Arruga Vivas <rosen644835@gmail.com>2020-10-24 17:38:58 +0200
commitef6596a20cac24dbfd729098f2a903f00f4e33e2 (patch)
tree83b7fdfedb6131e853bfc643b86fe5ee0d534ab3
parent31c894c652aac27bd0ed8594a4344fd7c2b31e6e (diff)
downloadguix-ef6596a20cac24dbfd729098f2a903f00f4e33e2.tar
guix-ef6596a20cac24dbfd729098f2a903f00f4e33e2.tar.gz
build: Add GUIX_GIT_KEYRING variable for make authenticate.
* Makefile.am (GUIX_GIT_KEYRING): New variable. (authenticate): Use GUIX_GIT_KEYRING to select the keyring branch reference. * doc/contributing.texi (Building from Git): Add an example about the use of GUIX_GIT_KEYRING.
-rw-r--r--Makefile.am2
-rw-r--r--doc/contributing.texi10
2 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c509562567..e6cef9ec1a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -666,9 +666,11 @@ channel_intro_commit = 9edb3f66fd807b096b48283debdcddccfea34bad
channel_intro_signer = BBB0 2DDF 2CEA F6A8 0D1D E643 A2A0 6DF2 A33A 54FA
# Authenticate the current Git checkout by checking signatures on every commit.
+GUIX_GIT_KEYRING = origin/keyring
authenticate:
$(AM_V_at)echo "Authenticating Git checkout..." ; \
guix git authenticate \
+ --keyring=$(GUIX_GIT_KEYRING) \
--cache-key=channels/guix --stats \
"$(channel_intro_commit)" "$(channel_intro_signer)"
diff --git a/doc/contributing.texi b/doc/contributing.texi
index 26a4627464..d3f6325c3f 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -140,6 +140,16 @@ make authenticate
The first run takes a couple of minutes, but subsequent runs are faster.
+Or, when your configuration for your local Git repository doesn't match
+the default one, you can provide the reference for the @code{keyring}
+branch through the variable @code{GUIX_GIT_KEYRING}. The following
+example assumes that you have a Git remote called @samp{myremote}
+pointing to the official repository:
+
+@example
+make authenticate GUIX_GIT_KEYRING=myremote/keyring
+@end example
+
@quotation Note
You are advised to run @command{make authenticate} after every
@command{git pull} invocation. This ensures you keep receiving valid