aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-10-01 00:06:25 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-01 00:13:41 +0200
commit7c413c3575371557dc3998b2a65c36ca1ada2cd6 (patch)
tree07b112973f9e2a54d32ea921e9e6be45c24dc03c
parent7f2ee827fe40d836f12276ed76bc4042a5f4331b (diff)
downloadguix-7c413c3575371557dc3998b2a65c36ca1ada2cd6.tar
guix-7c413c3575371557dc3998b2a65c36ca1ada2cd6.tar.gz
gnu: nginx-xslscript: Move out of the way.
The nginx and nginx-documentation packages need to be updated in tandem. nginx-xslscript has no good reason to come between them. * gnu/packages/web.scm (nginx-xslscript): Relocate.
-rw-r--r--gnu/packages/web.scm84
1 files changed, 42 insertions, 42 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 9de9f873a5..1912e590cf 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -318,48 +318,6 @@ and as a proxy to reduce the load on back-end HTTP or mail servers.")
;; except for two source files which are bsd-4 licensed.
(license (list license:bsd-2 license:expat license:bsd-3 license:bsd-4))))
-(define nginx-xslscript
- (let ((revision 11)
- (changeset "01dc9ba12e1b"))
- (package
- (name "nginx-xslscript")
- (version
- (simple-format #f "2014-03-31-~A-~A" revision changeset))
- (source (origin
- (method hg-fetch)
- (uri (hg-reference
- (url "http://hg.nginx.org/xslscript")
- (changeset changeset)))
- (file-name (string-append name "-" version))
- (sha256
- (base32
- "0am8zvdx3jmiwkg5q07qjaw5r26r4i2v5i4yr8a1k0jgib6ii08g"))))
- (build-system gnu-build-system)
- (arguments
- '(#:tests? #f ; No test suite
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (delete 'build)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out-bin (string-append
- (assoc-ref outputs "out")
- "/bin")))
- (mkdir-p out-bin)
- (copy-file "xslscript.pl"
- (string-append
- out-bin
- "/xslscript.pl"))
- #t))))))
- (home-page "http://hg.nginx.org/xslscript")
- (synopsis "XSLScript with NGinx specific modifications")
- (description
- "XSLScript is a terse notation for writing complex XSLT stylesheets.
-This is modified version, specifically intended for use with the NGinx
-documentation.")
- (license license:bsd-2))))
-
(define-public nginx-documentation
;; This documentation should be relevant for the current nginx package.
(let ((version "1.19.3")
@@ -549,6 +507,48 @@ supported at your website.")
;; binary:
(package-license nginx)))))))
+(define nginx-xslscript
+ (let ((revision 11)
+ (changeset "01dc9ba12e1b"))
+ (package
+ (name "nginx-xslscript")
+ (version
+ (simple-format #f "2014-03-31-~A-~A" revision changeset))
+ (source (origin
+ (method hg-fetch)
+ (uri (hg-reference
+ (url "http://hg.nginx.org/xslscript")
+ (changeset changeset)))
+ (file-name (string-append name "-" version))
+ (sha256
+ (base32
+ "0am8zvdx3jmiwkg5q07qjaw5r26r4i2v5i4yr8a1k0jgib6ii08g"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; No test suite
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out-bin (string-append
+ (assoc-ref outputs "out")
+ "/bin")))
+ (mkdir-p out-bin)
+ (copy-file "xslscript.pl"
+ (string-append
+ out-bin
+ "/xslscript.pl"))
+ #t))))))
+ (home-page "http://hg.nginx.org/xslscript")
+ (synopsis "XSLScript with NGinx specific modifications")
+ (description
+ "XSLScript is a terse notation for writing complex XSLT stylesheets.
+This is modified version, specifically intended for use with the NGinx
+documentation.")
+ (license license:bsd-2))))
+
(define-public lighttpd
(package
(name "lighttpd")