aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-10-24 23:11:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-10-24 23:13:43 +0300
commit6f588bb16c45fca5cec0e7c8bfdefa22d5b94797 (patch)
treeb98418bd7fd7f48ce4e0bf5237d4d0a8e106af3f
parentf78681206680fd09f3d97c656c00cfcb79c40be3 (diff)
downloadguix-6f588bb16c45fca5cec0e7c8bfdefa22d5b94797.tar
guix-6f588bb16c45fca5cec0e7c8bfdefa22d5b94797.tar.gz
gnu: gtranslator: Fix running on non-gnome desktops.
* gnu/packages/gnome.scm (gtranslator)[arguments]: Build with glib-or-gtk support.
-rw-r--r--gnu/packages/gnome.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c7f65266d8..b8a2c38a5f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12011,9 +12011,10 @@ your data.")
`(("gtksourceview" ,gtksourceview))) ; required for source view
(arguments
`(#:build-type "release"
+ #:glib-or-gtk? #t
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'skip-gtk-update-icon-cache
+ (add-after 'unpack 'skip-gtk-update-icon-cache
(lambda _
(substitute* "build-aux/meson/meson_post_install.py"
(("gtk-update-icon-cache") (which "true")))