aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-10-19 19:27:01 +0100
committerChristopher Baines <mail@cbaines.net>2020-10-24 20:03:27 +0100
commit0b4ac3b17cb953a07f6222e870adeee669bcdd5b (patch)
tree4c410ae94ac7398721e6f2fd28f595e8549fcbb2
parentef6596a20cac24dbfd729098f2a903f00f4e33e2 (diff)
downloadguix-0b4ac3b17cb953a07f6222e870adeee669bcdd5b.tar
guix-0b4ac3b17cb953a07f6222e870adeee669bcdd5b.tar.gz
gnu: Add python-yq.
* gnu/packages/python-xyz.scm (python-yq): New variable.
-rw-r--r--gnu/packages/python-xyz.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e3f8589249..2ac77ffde9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17357,6 +17357,47 @@ style guide, even if the original code didn't violate the style guide.")
(define-public python2-yapf
(package-with-python2 python-yapf))
+(define-public python-yq
+ (package
+ (name "python-yq")
+ (version "2.11.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "yq" version))
+ (sha256
+ (base32
+ "1q4rky0a6n4izmq7slb91a54g8swry1xrbfqxwc8lkd3hhvlxxkl"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "yq/__init__.py"
+ (("Popen\\(\\[\"jq")
+ (string-append
+ "Popen([\""
+ (assoc-ref inputs "jq")
+ "/bin/jq")))
+ #t)))))
+ (inputs
+ `(("python-argcomplete" ,python-argcomplete)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-xmltodict" ,python-xmltodict)
+ ("jq" ,jq)))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-flake8" ,python-flake8)
+ ("python-wheel" ,python-wheel)))
+ (home-page "https://github.com/kislyuk/yq")
+ (synopsis "Command-line YAML/XML processor")
+ (description
+ "This package provides @command{yq} and @command{xq} for processing YAML
+and XML respectively. The processing is done through @{jq}, @command{jq}
+filters can be used to process the data as it passes through.")
+ (license license:asl2.0)))
+
(define-public python-gyp
(let ((commit "5e2b3ddde7cda5eb6bc09a5546a76b00e49d888f")
(revision "0"))