aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-09 21:46:50 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-10 17:45:38 +0100
commitfba9a660954f77ef8ba0c481345ded9b7948ec22 (patch)
tree0b751db6ec1cfb30e6e92cc563ccd6866ce586b2
parent9ce09a7698e91e907cea112c12d4837de27324dd (diff)
downloadguix-fba9a660954f77ef8ba0c481345ded9b7948ec22.tar
guix-fba9a660954f77ef8ba0c481345ded9b7948ec22.tar.gz
gnu: xinetd: Don't use unstable tarball.
* gnu/packages/web.scm (xinetd)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/web.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 45ea77ad36..158d542d7f 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -16,7 +16,7 @@
;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2016, 2017 Nils Gillmann <ng0@n0.is>
;;; Copyright © 2016, 2017, 2018, 2019 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016, 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Bake Timmons <b3timmons@speedymail.org>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
@@ -4877,15 +4877,17 @@ additional capabilities.")
(version "2.3.15")
(source
(origin
- (method url-fetch)
- (uri
- (string-append "https://github.com/xinetd-org/xinetd/archive/xinetd-"
- (string-join (string-split version #\.) "-") ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xinetd-org/xinetd.git")
+ (commit (string-append "xinetd-"
+ (string-join (string-split version #\.)
+ "-")))))
+ (file-name (git-file-name name version))
(patches (search-patches "xinetd-CVE-2013-4342.patch"
"xinetd-fix-fd-leak.patch"))
(sha256
- (base32
- "0k59x52cbzp5fw0n8zn0y54j1ps0x9b72y8k5grzswjdmgs2a2v2"))))
+ (base32 "0wjai6qagcgxpa1khh639ih7kswgkryc7ll1i4hxhs29sc7irdcn"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--with-loadavg")