aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-10 11:59:31 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-10 17:45:40 +0100
commit951bdf5adfd52f0d646244a2090dbfa52d868c37 (patch)
tree44261919f414f8062a5a15f1aacc2ce71eac83c8
parent00fc938983f70f9ff9522133380a48495a5a4114 (diff)
downloadguix-951bdf5adfd52f0d646244a2090dbfa52d868c37.tar
guix-951bdf5adfd52f0d646244a2090dbfa52d868c37.tar.gz
gnu: java-jdom2: Don't use unstable tarball.
* gnu/packages/xml.scm (java-jdom2)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/xml.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index f216482790..e09fde733f 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1960,16 +1960,18 @@ implements @code{XMLStreamWriter} and @code{XMLStreamReader} and supports
(name "java-jdom")
(version "2.0.6")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/hunterhacker/jdom/archive/JDOM-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hunterhacker/jdom.git")
+ (commit (string-append "JDOM-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0p8n7inqq2a25wk9ljinl3ixlx1x2la9qaman8ngd75xxjb02yc1"))))
+ "14vv1kxrsdvwi4cz3rx6r48w5y6fvk9cymil8qhvxwp56xxrgxiq"))))
(build-system ant-build-system)
(arguments
`(#:build-target "package"
- #:tests? #f; tests are run as part of the build process
+ #:tests? #f ; tests are run as part of the build process
#:phases
(modify-phases %standard-phases
(replace 'install