aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2019-02-05 04:14:23 +0000
committerDanny Milosavljevic <dannym@scratchpost.org>2019-02-10 20:41:59 +0100
commit8c16b8a40ca3a77ee819b05d825b30671f1d536c (patch)
tree1c784c21152ab54d82fd941c1ad2ec35aa3dc089
parentf98232a39e955c9cb0cad151c939b8b94008c740 (diff)
downloadguix-8c16b8a40ca3a77ee819b05d825b30671f1d536c.tar
guix-8c16b8a40ca3a77ee819b05d825b30671f1d536c.tar.gz
gnu: python-trezor: Update to 0.11.1.
* gnu/packages/finance.scm (python-trezor): Update to 0.11.1. [arguments]: Remove obsolete "slow_cosi" test. Delete "test_tx_api" test, which requires network access. [propagated-inputs]: Add python-construct and python-typing-extensions, Remove python-hidapi, python-protobuf and python-typing. [native-inputs]: Remove python-mock, Add protobuf, python-black, python-protobuf and python-isort.
-rw-r--r--gnu/packages/finance.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 132d8845b4..e44be713f2 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -683,14 +683,14 @@ Ledger Blue/Nano S.")
(define-public python-trezor
(package
(name "python-trezor")
- (version "0.10.2")
+ (version "0.11.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "trezor" version))
(sha256
(base32
- "138k6zsqqpb46k3rcpyslm9q7yq5i6k4myvr9n425jnkadf4vfjd"))))
+ "064yds8f4px0c6grkkanpdjx022g4q87ihzhkmdv9qanv0hz6hv0"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -698,21 +698,23 @@ Ledger Blue/Nano S.")
;; Default tests run device-specific tests which fail, only run specific tests.
(replace 'check
(lambda* (#:key inputs outputs #:allow-other-keys)
- (invoke "python" "-m" "pytest" "--pyarg" "trezorlib.tests.unit_tests")
- (invoke "python" "-m" "pytest" "-m" "slow_cosi" "--pyarg" "trezorlib.tests.unit_tests")
- )))))
+ ;; Delete tests that require network access.
+ (delete-file "trezorlib/tests/unit_tests/test_tx_api.py")
+ (invoke "python" "-m" "pytest" "--pyarg" "trezorlib.tests.unit_tests"))))))
(propagated-inputs
`(("python-click" ,python-click)
+ ("python-construct" ,python-construct)
("python-ecdsa" ,python-ecdsa)
- ("python-hidapi" ,python-hidapi)
("python-libusb1" ,python-libusb1)
("python-mnemonic" ,python-mnemonic)
- ("python-protobuf" ,python-protobuf)
("python-pyblake2" ,python-pyblake2)
("python-requests" ,python-requests)
- ("python-typing" ,python-typing)))
+ ("python-typing-extensions" ,python-typing-extensions)))
(native-inputs
- `(("python-mock" ,python-mock) ; Tests
+ `(("protobuf" ,protobuf) ; Tests
+ ("python-black" ,python-black) ; Tests
+ ("python-protobuf" ,python-protobuf) ; Tests
+ ("python-isort" ,python-isort) ; Tests
("python-pyqt" ,python-pyqt) ; Tests
("python-pytest" ,python-pytest))) ; Tests
(home-page "https://github.com/trezor/python-trezor")