aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-10 00:39:02 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-10 17:45:38 +0100
commit62dbf78b65424bf8c03a47338bcfba1fa5786246 (patch)
treef860409e4100b7a3714f1b6502bd74a52f9628d3
parent85e0827d909ff352ee8f56ccb740a7d5913e560e (diff)
downloadguix-62dbf78b65424bf8c03a47338bcfba1fa5786246.tar
guix-62dbf78b65424bf8c03a47338bcfba1fa5786246.tar.gz
gnu: clojure-algo-monads: Don't use unstable tarball.
* gnu/packages/clojure.scm (clojure-algo-monads)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/clojure.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/clojure.scm b/gnu/packages/clojure.scm
index 2f82f347b6..8e09cfa69d 100644
--- a/gnu/packages/clojure.scm
+++ b/gnu/packages/clojure.scm
@@ -173,12 +173,13 @@ that can be implemented for any data type.")
(version "0.1.6")
(source
(origin
- (method url-fetch)
- (uri
- (string-append "https://github.com/clojure/algo.monads/archive"
- "/algo.monads-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/clojure/algo.monads.git")
+ (commit (string-append "algo.monads-" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "14gbvfgmrda990h45yn7zag83vp1kdkz4f4yzmyvkr0sjihlgdmq"))))
+ (base32 "0mv3ba72hyhgasg2k3zy83ij61gak6cs4d6qgh8123z3j02mbh8p"))))
(build-system clojure-build-system)
(arguments
'(#:source-dirs '("src/main/clojure/")