aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-10 02:37:28 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-10 17:45:40 +0100
commit00fc938983f70f9ff9522133380a48495a5a4114 (patch)
tree13debb270f50bbeb7e1df4f4c9d9754a1a0f3265
parent9d67052661676f4835280f5a151637701c319264 (diff)
downloadguix-00fc938983f70f9ff9522133380a48495a5a4114.tar
guix-00fc938983f70f9ff9522133380a48495a5a4114.tar.gz
gnu: java-kxml2: Don't use unstable tarball.
* gnu/packages/xml.scm (java-kxml2)[source]: Use GIT-FETCH and GIT-FILE-NAME. [arguments]: Add 'make-git-checkout-writable' phase.
-rw-r--r--gnu/packages/xml.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 80dd6fb709..f216482790 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1856,13 +1856,14 @@ low memory footprint.")
(name "java-kxml2")
(version "2.4.2")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/stefanhaustein/kxml2/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stefanhaustein/kxml2.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "17kh04qf3vll1xx6sv06xlazw2hxa8qdmzyday9r6z2191jlj74w"))))
+ "0g6d8c9r9sh3x04sf4wdpgwvhkqvk11k3kq9skx91i60h4vn01hg"))))
(build-system ant-build-system)
(arguments
`(#:jar-name "kxml2.jar"
@@ -1873,6 +1874,10 @@ low memory footprint.")
#:tests? #f
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'make-git-checkout-writable
+ (lambda _
+ (for-each make-file-writable (find-files "."))
+ #t))
(add-before 'build 'copy-resources
(lambda _
(copy-recursively "src/main/resources" "build/classes")