aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZ572 <873216071@qq.com>2020-12-25 15:23:53 +0800
committerChristopher Baines <mail@cbaines.net>2020-12-31 22:24:03 +0000
commitf59bfc11175c838fe949f1a699d98a1df82dc337 (patch)
treef60e8ff5cf0edf7c183b19f9a38550001123b06a
parent777ecc1eeb082cf6c8a8e8489279af9d0e2195e2 (diff)
downloadguix-f59bfc11175c838fe949f1a699d98a1df82dc337.tar
guix-f59bfc11175c838fe949f1a699d98a1df82dc337.tar.gz
gnu: Add yakuake.
* gnu/packages/kde-systemtools.scm (yakuake): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/kde-systemtools.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/kde-systemtools.scm b/gnu/packages/kde-systemtools.scm
index 0fbf6e3373..f5d97dae27 100644
--- a/gnu/packages/kde-systemtools.scm
+++ b/gnu/packages/kde-systemtools.scm
@@ -318,3 +318,52 @@ who want to quickly see problems occurring on their server.
This package is part of the KDE administration module.")
(license license:gpl2+)))
+
+(define-public yakuake
+ (package
+ (name "yakuake")
+ (version "20.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/yakuake-" version ".tar.xz"))
+ (sha256
+ (base32
+ "175vvkpkpbd7nm0lqjyiw27xmfdfcs9syvfngnjlndmlzwagk8d1"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("breeze-icons" ,breeze-icons)
+ ("karchive" ,karchive)
+ ("kconfig" ,kconfig)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("kglobalaccel" ,kglobalaccel)
+ ("ki18n" ,ki18n)
+ ("kiconthemes" ,kiconthemes)
+ ("kio" ,kio)
+ ("knewstuff" ,knewstuff)
+ ("knotifications" ,knotifications)
+ ("knotifyconfig" ,knotifyconfig)
+ ("konsole" ,konsole)
+ ("kparts" ,kparts)
+ ("kwayland" ,kwayland)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kwindowsystem" ,kwindowsystem)
+ ("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)
+ ("qtx11extras" ,qtx11extras)))
+ (home-page "https://www.kde.org/applications/system/yakuake/")
+ (synopsis "Quad-style terminal emulator for KDE")
+ (description "Yakuake is a drop-down terminal emulator based on KDE Konsole
+technology. Features include:
+@itemize
+@item Smoothly rolls down from the top of your screen
+@item Tabbed interface
+@item Configurable dimensions and animation speed
+@item Skinnable
+@item Sophisticated D-Bus interface
+@end itemize")
+ (license license:gpl2+)))