aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2021-01-01 12:04:24 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2021-01-01 12:04:46 +0300
commit153151a865cfae5e7f8c8d98be78b238a6cc7a33 (patch)
tree3992847e5430a0bb36660dcb714332837474a5a7
parentfdf7095e856c3c13a54baee5d942d14e96f7fb4d (diff)
downloadguix-153151a865cfae5e7f8c8d98be78b238a6cc7a33.tar
guix-153151a865cfae5e7f8c8d98be78b238a6cc7a33.tar.gz
Revert "gnu: tigervnc-client: Update to 1.11.0."
This reverts commit 776c700aafb380ffc72f10cc463c6dfeb35dd7c1 with missing /gnu/store/...-tigervnc-server-1.11.0/bin/vncserver binary.
-rw-r--r--gnu/packages/vnc.scm86
1 files changed, 42 insertions, 44 deletions
diff --git a/gnu/packages/vnc.scm b/gnu/packages/vnc.scm
index b8979b2921..ab89bad7aa 100644
--- a/gnu/packages/vnc.scm
+++ b/gnu/packages/vnc.scm
@@ -1,9 +1,8 @@
-;; GNU Guix --- Functional package management for GNU
+;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Todor Kondić <tk.code@protonmail.com>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
-;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -42,56 +41,55 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages sdl)
#:use-module (gnu packages tls)
- #:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg))
(define-public tigervnc-client
- (package
- (name "tigervnc-client")
- (version "1.11.0")
- (source (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/TigerVNC/tigervnc")
- (commit (string-append "v" version))))
- (sha256
- (base32
- "1bg79ahr4mzy48ak0caxy3ckdsxmhpchypggaz6lxjjk92hgsz91"))
- (file-name (git-file-name name version))))
- (build-system cmake-build-system)
- (arguments
- '(#:tests? #f ; Tests that do exists are not automated.
- #:phases (modify-phases %standard-phases
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (with-directory-excursion "vncviewer"
- (invoke "make" "install")))))))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("gettext-minimal" ,gettext-minimal)
- ("automake" ,automake)))
- (inputs
- `(("zlib" ,zlib)
- ("gnutls" ,gnutls)
- ("libjpeg-turbo" ,libjpeg-turbo)
- ("fltk" ,fltk)
- ("linux-pam" ,linux-pam)
- ("libx11" ,libx11)
- ("libxext" ,libxext)
- ("libxtst" ,libxtst)
- ("libxrandr" ,libxrandr)
- ("libxdamage" ,libxdamage)
- ("pixman" ,pixman)))
- (home-page "https://tigervnc.org/")
- (synopsis "High-performance, platform-neutral
+ (let ((commit "920d9c4d6562ecabf79497bc901d50522d4bc661"))
+ (package
+ (name "tigervnc-client")
+ (version (git-version "1.10.1" "1" commit))
+ (source (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/TigerVNC/tigervnc")
+ (commit commit)))
+ (sha256
+ (base32
+ "1lp6mxl5dqlkrzx0q145jzgpbwvhsni3fj6x9ngf8v5s63x82q1p"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f ; Tests that do exists are not automated.
+ #:phases (modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (with-directory-excursion "vncviewer"
+ (invoke "make" "install")))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("gettext-minimal" ,gettext-minimal)
+ ("automake" ,automake)))
+ (inputs
+ `(("zlib" ,zlib)
+ ("gnutls" ,gnutls)
+ ("libjpeg-turbo" ,libjpeg-turbo)
+ ("fltk" ,fltk)
+ ("linux-pam" ,linux-pam)
+ ("libx11" ,libx11)
+ ("libxext" ,libxext)
+ ("libxtst" ,libxtst)
+ ("libxrandr" ,libxrandr)
+ ("libxdamage" ,libxdamage)))
+ (home-page "https://tigervnc.org/")
+ (synopsis "High-performance, platform-neutral
implementation of VNC (client)")
- (description "TigerVNC is a client/server implementation of VNC (Virtual
+ (description "TigerVNC is a client/server implementation of VNC (Virtual
Network Computing). It provides enough performance to run even 3D and video
applications. It also provides extensions for advanced authentication methods
and TLS encryption. This package installs only the VNC client, the
application which is needed to connect to VNC servers.")
- (license license:gpl2)))
+ (license license:gpl2))))
;; A VNC server is, in fact, an X server so it seems like a good idea
;; to build on the work already done for xorg-server package. This is