aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-10-06 03:32:12 -0400
committerLeo Famulari <leo@famulari.name>2018-10-06 04:11:26 -0400
commite90ce1157794bfecfe93f7c31dc4bd631dd710fb (patch)
treec6ea9fa7574b559bf0758650f6efdac0702eaa67
parentd71078bc75d149c70dc573a259986f1731145693 (diff)
downloadguix-e90ce1157794bfecfe93f7c31dc4bd631dd710fb.tar
guix-e90ce1157794bfecfe93f7c31dc4bd631dd710fb.tar.gz
gnu: git: Update to 2.19.1 [fixes CVE-2018-17456].
* gnu/packages/version-control.scm (git): Update to 2.19.1.
-rw-r--r--gnu/packages/version-control.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index cc892b9c62..00d7e1f189 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -146,14 +146,14 @@ as well as the classic centralized workflow.")
(name "git")
;; XXX When updating Git, check if the special 'git-source' input to cgit
;; needs to be updated as well.
- (version "2.19.0")
+ (version "2.19.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "1x1y5z3awabmfg7hk6zb331jxngad4nal4507v96bnf0izsyy3qq"))))
+ "1dfv43lmdnxz42504jc89sihbv1d4d6kgqcz3c5ji140kfm5cl1l"))))
(build-system gnu-build-system)
(native-inputs
`(("native-perl" ,perl)
@@ -166,7 +166,7 @@ as well as the classic centralized workflow.")
version ".tar.xz"))
(sha256
(base32
- "1jvxiqvp9q4is3np063ny7rnmk5hm36d34bhi3cgv89njqdh8laf"))))))
+ "1vn6pi9yvw7rnb9dvi1yjrvv39fqd1m9mwbaffqwizs3gaf91br7"))))))
(inputs
`(("curl" ,curl)
("expat" ,expat)