aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-10-02 18:38:04 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-05 23:59:26 +0200
commitd9ee3e375ca54bb6f4fd6bbc5b3646e27a0c25d0 (patch)
tree6d6944d37d02340a28246b28fa7cacdb6a2a27bd
parent9ef95a196f5144506eb92e3870de96a180454643 (diff)
downloadguix-d9ee3e375ca54bb6f4fd6bbc5b3646e27a0c25d0.tar
guix-d9ee3e375ca54bb6f4fd6bbc5b3646e27a0c25d0.tar.gz
gnu: Add ghc-inline-c-cpp.
* gnu/packages/haskell.scm (ghc-inline-c-cpp): New variable.
-rw-r--r--gnu/packages/haskell.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 5d68ddcada..9e47c4cbfc 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11213,4 +11213,40 @@ encourages best practices to minimize the chances of getting the exception
handling wrong.")
(license license:expat)))
+(define-public ghc-inline-c-cpp
+ (package
+ (name "ghc-inline-c-cpp")
+ (version "0.2.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/inline-c-cpp/"
+ "inline-c-cpp-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1rk7fmpkmxw9hhwr8df29kadnf0ybnwj64ggdbnsdrpfyhnkisci"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'create-Setup.hs
+ (lambda _
+ (with-output-to-file "Setup.hs"
+ (lambda _
+ (display "\
+import Distribution.Simple
+main = defaultMain")))
+ #t)))))
+ (inputs
+ `(("ghc-inline-c" ,ghc-inline-c)
+ ("ghc-safe-exceptions" ,ghc-safe-exceptions)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)))
+ (home-page "https://hackage.haskell.org/package/inline-c-cpp")
+ (synopsis "Lets you embed C++ code into Haskell")
+ (description
+ "This package provides utilities to inline C++ code into Haskell using
+@code{inline-c}.")
+ (license license:expat)))
+
;;; haskell.scm ends here