aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-04 19:52:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-10-04 21:28:24 +0200
commitd8b042326dda505c8e65789572e3dd65311ba8e3 (patch)
tree6c52e54fdf736d308807de72655762842cd9c748
parentb9b53fb4ffa188a2dad2b3062a552877f1124750 (diff)
downloadguix-d8b042326dda505c8e65789572e3dd65311ba8e3.tar
guix-d8b042326dda505c8e65789572e3dd65311ba8e3.tar.gz
gnu: hiawatha: Set sane run-time directory defaults.
* gnu/packages/web.scm (hiawatha)[arguments]: Set sane default directories. Replace the 'remove-empty-dirs' phase with a 'install-no-empty-directories' one.
-rw-r--r--gnu/packages/web.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 01db03e79d..c3b06b05bc 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5195,17 +5195,20 @@ functions of Tidy.")
(string-append "-DENABLE_HTTP2=on")
(string-append "-DUSE_SYSTEM_NGHTTP2=on")
(string-append "-DENABLE_TOMAHAWK=on")
+ (string-append "-DLOG_DIR=/var/log/hiawatha")
+ (string-append "-DPID_DIR=/run")
(string-append "-DWEBROOT_DIR="
(assoc-ref %outputs "out")
- "/share/hiawatha/html"))
+ "/share/hiawatha/html")
+ (string-append "-DWORK_DIR=/var/lib/hiawatha"))
#:phases
(modify-phases %standard-phases
- (add-after 'install 'remove-empty-dirs
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out")))
- ;; The directories in "var" are empty, remove them.
- (delete-file-recursively (string-append out "/var"))
- #t)))
+ (add-after 'unpack 'install-no-empty-directories
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("install\\(DIRECTORY DESTINATION" match)
+ (string-append "#" match)))
+ #t))
(add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Make sure 'hiawatha' finds 'mbedtls'.