aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-10-02 18:32:38 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-05 23:59:26 +0200
commitd05ed20ef12e5c9520252f2da230c54f46de703d (patch)
treeb1ea775f286a791b4d601067066e3696152cbace
parent6c8197783dca26159a669202a0635af0338d4992 (diff)
downloadguix-d05ed20ef12e5c9520252f2da230c54f46de703d.tar
guix-d05ed20ef12e5c9520252f2da230c54f46de703d.tar.gz
gnu: Add ghc-cereal-conduit.
* gnu/packages/haskell.scm (ghc-cereal-conduit): New variable.
-rw-r--r--gnu/packages/haskell.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index c1815c60da..a8d22a682a 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -10726,6 +10726,33 @@ will destroy the permissions on the original file. This library preserves
permissions while atomically writing to a file.")
(license license:expat)))
+(define-public ghc-cereal-conduit
+ (package
+ (name "ghc-cereal-conduit")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "cereal-conduit/cereal-conduit-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1srr7agvgfw78q5s1npjq5sgynvhjgllpihiv37ylkwqm4c4ap6r"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-conduit" ,ghc-conduit)
+ ("ghc-resourcet" ,ghc-resourcet)
+ ("ghc-cereal" ,ghc-cereal)))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)))
+ (home-page "https://github.com/snoyberg/conduit")
+ (synopsis "Turn Data.Serialize Gets and Puts into Sources, Sinks, and Conduits")
+ (description
+ "This package turn @code{Data.Serialize} @code{Gets} and @code{Puts} into
+@code{Sources}, @code{Sinks}, and @code{Conduits}.")
+ (license license:bsd-3)))
+
(define-public ghc-weigh
(package
(name "ghc-weigh")