aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-10-02 18:38:08 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-05 23:59:26 +0200
commitc7e400b1eefd627e634a9624f4f68f217d55715d (patch)
tree17a4a32055c3f71f2667e5ec9591ebe8289e3877
parentd453b899448bd1dc909e7ef279d52940a95031e0 (diff)
downloadguix-c7e400b1eefd627e634a9624f4f68f217d55715d.tar
guix-c7e400b1eefd627e634a9624f4f68f217d55715d.tar.gz
gnu: Add ghc-configurator.
* gnu/packages/haskell.scm (ghc-configurator): New variable.
-rw-r--r--gnu/packages/haskell.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 33354e883b..af44232cee 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11270,4 +11270,47 @@ main = defaultMain")))
from strict or lazy bytestrings.")
(license license:bsd-2)))
+(define-public ghc-configurator
+ (package
+ (name "ghc-configurator")
+ (version "0.3.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "configurator/configurator-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1d1iq1knwiq6ia5g64rw5hqm6dakz912qj13r89737rfcxmrkfbf"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-hashable" ,ghc-hashable)
+ ("ghc-text" ,ghc-text)
+ ("ghc-unix-compat" ,ghc-unix-compat)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)))
+ (home-page "http://github.com/bos/configurator")
+ (synopsis "Configuration management")
+ (description
+ "This package provides a configuration management library for programs
+and daemons. The features include:
+
+@enumerate
+@item Automatic, dynamic reloading in response to modifications to
+ configuration files.
+@item A simple, but flexible, configuration language, supporting several of
+ the most commonly needed types of data, along with interpolation of strings
+ from the configuration or the system environment (e.g. @code{$(HOME)}).
+@item Subscription-based notification of changes to configuration properties.
+@item An @code{import} directive allows the configuration of a complex
+ application to be split across several smaller files, or common configuration
+ data to be shared across several applications.
+@end enumerate\n")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here