aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-10-02 18:32:52 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-05 23:59:26 +0200
commita933cbfb617d84d37e270b4dd89f2de92013834d (patch)
tree1e5897defe15ae268761fc1529db6194ef30a9cb
parent71c2e3e1a1a0416e6d09eee2691cf4c0decd9be5 (diff)
downloadguix-a933cbfb617d84d37e270b4dd89f2de92013834d.tar
guix-a933cbfb617d84d37e270b4dd89f2de92013834d.tar.gz
gnu: Add ghc-conduit-algorithms.
* gnu/packages/haskell.scm (ghc-conduit-algorithms): New variable.
-rw-r--r--gnu/packages/haskell.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 80d331c466..befb1baae5 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -10929,6 +10929,48 @@ streaming compression and decompression.")
based on a binomial heap.")
(license license:bsd-3)))
+(define-public ghc-conduit-algorithms
+ (package
+ (name "ghc-conduit-algorithms")
+ (version "0.0.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "conduit-algorithms/conduit-algorithms-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "07gx2q3d1bbfw14q41rmqg0i4m018pci10lswc0k1ij6lw7sb9fd"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-async" ,ghc-async)
+ ("ghc-bzlib-conduit" ,ghc-bzlib-conduit)
+ ("ghc-conduit" ,ghc-conduit)
+ ("ghc-conduit-combinators" ,ghc-conduit-combinators)
+ ("ghc-conduit-extra" ,ghc-conduit-extra)
+ ("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-lzma-conduit" ,ghc-lzma-conduit)
+ ("ghc-monad-control" ,ghc-monad-control)
+ ("ghc-pqueue" ,ghc-pqueue)
+ ("ghc-resourcet" ,ghc-resourcet)
+ ("ghc-stm" ,ghc-stm)
+ ("ghc-stm-conduit" ,ghc-stm-conduit)
+ ("ghc-streaming-commons" ,ghc-streaming-commons)
+ ("ghc-unliftio-core" ,ghc-unliftio-core)
+ ("ghc-vector" ,ghc-vector)))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
+ ("ghc-test-framework-th" ,ghc-test-framework-th)))
+ (home-page "https://github.com/luispedro/conduit-algorithms#readme")
+ (synopsis "Conduit-based algorithms")
+ (description
+ "This package provides algorithms on @code{Conduits}, including higher
+level asynchronous processing and some other utilities.")
+ (license license:expat)))
+
(define-public ghc-weigh
(package
(name "ghc-weigh")