aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-04 21:34:16 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-05 09:21:54 +0200
commit8e72f0f3190443935c03264037c83099ed68445f (patch)
tree51e31c5b7fa487145fd2e83873dc863987da9e69
parent939882f73430ae7644b3c7913cb389cf00c234e0 (diff)
downloadguix-8e72f0f3190443935c03264037c83099ed68445f.tar
guix-8e72f0f3190443935c03264037c83099ed68445f.tar.gz
gnu: deeptools: Update to 3.1.2.
* gnu/packages/bioinformatics.scm (deeptools): Update to 3.1.2. [source]: Fetch from git. [arguments]: Delete reset-gzip-timestamps phase. [inputs]: Add python-plotly.
-rw-r--r--gnu/packages/bioinformatics.scm21
1 files changed, 14 insertions, 7 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4c1739f1b1..39c84bf4c8 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2006,18 +2006,25 @@ with Python.")
(define-public deeptools
(package
(name "deeptools")
- (version "2.5.1")
+ (version "3.1.2")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/deeptools/deepTools/"
- "archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/deeptools/deepTools.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1q8i12l2gvk4n2s8lhyzwhh9g4qbc8lrk5l7maz00yvd5g6z5540"))))
+ "06fdpp6cg3xiwryxjhixvfysl4z0ps1crjgia587qa9ikqpsa7fd"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; This phase fails, but it's not needed.
+ (delete 'reset-gzip-timestamps))))
(inputs
- `(("python-scipy" ,python-scipy)
+ `(("python-plotly" ,python-plotly)
+ ("python-scipy" ,python-scipy)
("python-numpy" ,python-numpy)
("python-numpydoc" ,python-numpydoc)
("python-matplotlib" ,python-matplotlib)