aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-10-02 18:38:00 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-05 23:59:26 +0200
commit88189099dff99ecb4912c9c01adb920868049bec (patch)
tree9f114e5dd107e8c7b37f05ff38c0177d9cea9f04
parent52f5114d016688fb143079056a64b8abfb319507 (diff)
downloadguix-88189099dff99ecb4912c9c01adb920868049bec.tar
guix-88189099dff99ecb4912c9c01adb920868049bec.tar.gz
gnu: Add ghc-inline-c.
* gnu/packages/haskell.scm (ghc-inline-c): New variable.
-rw-r--r--gnu/packages/haskell.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 6b8a4ee3fc..9bc86bfbd3 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11069,6 +11069,52 @@ backslashes. They are useful when working with regular expressions,
DOS/Windows paths and markup languages (such as XML).")
(license license:bsd-3)))
+(define-public ghc-inline-c
+ (package
+ (name "ghc-inline-c")
+ (version "0.6.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/inline-c/"
+ "inline-c-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0vbfrsqsi7mdziqsnj68bsqlwbqxxhvrmy9rv6w8z18d1m8w3n6h"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'create-Setup.hs
+ (lambda _
+ (with-output-to-file "Setup.hs"
+ (lambda _
+ (display "\
+import Distribution.Simple
+main = defaultMain")))
+ #t)))))
+ (inputs
+ `(("ghc-ansi-wl-pprint" ,ghc-ansi-wl-pprint)
+ ("ghc-cryptohash" ,ghc-cryptohash)
+ ("ghc-hashable" ,ghc-hashable)
+ ("ghc-parsec" ,ghc-parsec)
+ ("ghc-parsers" ,ghc-parsers)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-vector" ,ghc-vector)))
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-hspec" ,ghc-hspec)
+ ("ghc-raw-strings-qq" ,ghc-raw-strings-qq)
+ ("ghc-regex-posix" ,ghc-regex-posix)))
+ (home-page "http://hackage.haskell.org/package/inline-c")
+ (synopsis "Write Haskell source files including C code inline")
+ (description
+ "inline-c lets you seamlessly call C libraries and embed high-performance
+inline C code in Haskell modules. Haskell and C can be freely intermixed in
+the same source file, and data passed to and from code in either language with
+minimal overhead. No FFI required.")
+ (license license:expat)))
+
(define-public ghc-weigh
(package
(name "ghc-weigh")