aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-04 22:16:36 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-10-05 19:30:09 +0200
commit8713c03e557114c576c796400300d0dbab4f06c8 (patch)
treec2505d1c87fc0b986c4fe58844740cf85d7a28db
parent3f904456923d6ba658ccf5f164511478f430afa5 (diff)
downloadguix-8713c03e557114c576c796400300d0dbab4f06c8.tar
guix-8713c03e557114c576c796400300d0dbab4f06c8.tar.gz
gnu: audacity: Don't use unstable tarball.
* gnu/packages/audio.scm (audacity)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/audio.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index c92b5056d1..434efab953 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -291,12 +291,14 @@ engineers, musicians, soundtrack editors and composers.")
(version "2.2.2")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/audacity/audacity/archive"
- "/Audacity-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/audacity/audacity.git")
+ (commit (string-append "Audacity-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "18q7i77ynihx7xp45lz2lv0k0wrh6736pcrivlpwrxjgbvyqx7km"))
+ "10maxmjxbmjybj7n4m7a9bbm7g8xxw8f8vbsf7c9ih5j2gr15ihs"))
(patches (search-patches "audacity-build-with-system-portaudio.patch"))
(modules '((guix build utils)))
(snippet