aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-10-02 18:32:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-05 23:59:26 +0200
commit80588cfccfd193d70491bb2a386667bf538dbb5d (patch)
treea31e9a88e863eb4b5130232f13fcbbcbd8363af8
parent36ec599e785ba3563ede377e05e8172c4323a2aa (diff)
downloadguix-80588cfccfd193d70491bb2a386667bf538dbb5d.tar
guix-80588cfccfd193d70491bb2a386667bf538dbb5d.tar.gz
gnu: Add ghc-stm-conduit.
* gnu/packages/haskell.scm (ghc-stm-conduit): New variable.
-rw-r--r--gnu/packages/haskell.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 3e10398966..d2f6a8b237 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -10784,6 +10784,45 @@ decompressing LZMA streams of data represented as lazy @code{ByteString}s. A
monadic incremental interface is provided as well.")
(license license:bsd-3)))
+(define-public ghc-stm-conduit
+ (package
+ (name "ghc-stm-conduit")
+ (version "4.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/stm-conduit/"
+ "stm-conduit-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0paapljn7nqfzrx889y0n8sszci38mdiaxkgr0bb00ph9246rr7z"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-stm" ,ghc-stm)
+ ("ghc-stm-chans" ,ghc-stm-chans)
+ ("ghc-cereal" ,ghc-cereal)
+ ("ghc-cereal-conduit" ,ghc-cereal-conduit)
+ ("ghc-conduit" ,ghc-conduit)
+ ("ghc-conduit-extra" ,ghc-conduit-extra)
+ ("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-resourcet" ,ghc-resourcet)
+ ("ghc-async" ,ghc-async)
+ ("ghc-monad-loops" ,ghc-monad-loops)
+ ("ghc-unliftio" ,ghc-unliftio)))
+ (native-inputs
+ `(("ghc-doctest" ,ghc-doctest)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
+ ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)))
+ (home-page "https://github.com/cgaebel/stm-conduit")
+ (synopsis "Introduces conduits to channels and promotes using conduits concurrently")
+ (description
+ "This package provides two simple conduit wrappers around STM channels: a
+source and a sink.")
+ (license license:bsd-3)))
+
(define-public ghc-weigh
(package
(name "ghc-weigh")