aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-10-02 18:32:50 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-05 23:59:26 +0200
commit71c2e3e1a1a0416e6d09eee2691cf4c0decd9be5 (patch)
tree2d3db714eefafb8c15d64c0d931d4f039cc59819
parent4fc161b9c60163f8353648a8e6e00d8229362ff4 (diff)
downloadguix-71c2e3e1a1a0416e6d09eee2691cf4c0decd9be5.tar
guix-71c2e3e1a1a0416e6d09eee2691cf4c0decd9be5.tar.gz
gnu: Add ghc-pqueue.
* gnu/packages/haskell.scm (ghc-pqueue): New variable.
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d79329f686..80d331c466 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -10907,6 +10907,28 @@ compression algorithm used in the @code{.xz} file format.")
streaming compression and decompression.")
(license license:bsd-3)))
+(define-public ghc-pqueue
+ (package
+ (name "ghc-pqueue")
+ (version "1.4.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "pqueue/pqueue-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1zvwm1zcqqq5n101s1brjhgbay8rf9fviq6gxbplf40i63m57p1x"))))
+ (build-system haskell-build-system)
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)))
+ (home-page "https://hackage.haskell.org/package/pqueue")
+ (synopsis "Reliable, persistent, fast priority queues")
+ (description
+ "This package provides a fast, reliable priority queue implementation
+based on a binomial heap.")
+ (license license:bsd-3)))
+
(define-public ghc-weigh
(package
(name "ghc-weigh")