aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-10-02 18:10:15 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-05 23:59:25 +0200
commit6c8197783dca26159a669202a0635af0338d4992 (patch)
tree91b9d6162dabcb35c97049674c83e44d22fafdc0
parent562cfae330e2b8382ab106478514d833187c7d15 (diff)
downloadguix-6c8197783dca26159a669202a0635af0338d4992.tar
guix-6c8197783dca26159a669202a0635af0338d4992.tar.gz
gnu: Add ghc-atomic-write.
* gnu/packages/haskell.scm (ghc-atomic-write): New variable.
-rw-r--r--gnu/packages/haskell.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index c040965e92..c1815c60da 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -10691,6 +10691,41 @@ documents, amongst others.")
backend for the Charts library.")
(license license:bsd-3)))
+(define-public ghc-atomic-write
+ (package
+ (name "ghc-atomic-write")
+ (version "0.2.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/atomic-write/atomic-write-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1iaq0hprxcv0sl1sgwcgmm87zraf738va1bciwnx2jkk3k1v9iyv"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-temporary" ,ghc-temporary)
+ ("ghc-unix-compat" ,ghc-unix-compat)
+ ("ghc-text" ,ghc-text)))
+ (native-inputs
+ `(("ghc-temporary" ,ghc-temporary)
+ ("ghc-unix-compat" ,ghc-unix-compat)
+ ("ghc-text" ,ghc-text)
+ ("ghc-hspec" ,ghc-hspec)
+ ("hspec-discover" ,hspec-discover)))
+ (home-page "https://github.com/stackbuilders/atomic-write")
+ (synopsis "Atomically write to a file")
+ (description
+ "Atomically write to a file on POSIX-compliant systems while preserving
+permissions. @code{mv} is an atomic operation. This makes it simple to write
+to a file atomically just by using the @code{mv} operation. However, this
+will destroy the permissions on the original file. This library preserves
+permissions while atomically writing to a file.")
+ (license license:expat)))
+
(define-public ghc-weigh
(package
(name "ghc-weigh")