aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-10-02 18:15:04 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-05 23:59:26 +0200
commit5e6bf3e2da6934daeadc36afeb8e09f105754efe (patch)
tree1bea333325c31038cf676b8ff0934993fbde2bfb
parent320323141f697483277918f411ecc62a8a7ab85d (diff)
downloadguix-5e6bf3e2da6934daeadc36afeb8e09f105754efe.tar
guix-5e6bf3e2da6934daeadc36afeb8e09f105754efe.tar.gz
gnu: Add ghc-hpack.
* gnu/packages/haskell.scm (ghc-hpack): New variable.
-rw-r--r--gnu/packages/haskell.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8a33cbd6b2..9a5f7c9746 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -10999,6 +10999,51 @@ level asynchronous processing and some other utilities.")
Haskell.")
(license license:expat)))
+(define-public ghc-hpack
+ (package
+ (name "ghc-hpack")
+ (version "0.28.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/hpack/"
+ "hpack-" version ".tar.gz"))
+ (sha256
+ (base32
+ "18w0h76jdp3mk9vin8da9iz3cwhcxmw787xy8wlh8bxcpcr16q5r"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-aeson" ,ghc-aeson)
+ ("ghc-bifunctors" ,ghc-bifunctors)
+ ("ghc-cryptonite" ,ghc-cryptonite)
+ ("ghc-glob" ,ghc-glob)
+ ("ghc-http-client" ,ghc-http-client)
+ ("ghc-http-client-tls" ,ghc-http-client-tls)
+ ("ghc-http-types" ,ghc-http-types)
+ ("ghc-scientific" ,ghc-scientific)
+ ("ghc-text" ,ghc-text)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-vector" ,ghc-vector)
+ ("ghc-yaml" ,ghc-yaml)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-interpolate" ,ghc-interpolate)
+ ("ghc-mockery" ,ghc-mockery)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-temporary" ,ghc-temporary)
+ ("hspec-discover" ,hspec-discover)))
+ (home-page "https://github.com/sol/hpack")
+ (synopsis "Tools for an alternative Haskell package format")
+ (description
+ "Hpack is a format for Haskell packages. It is an alternative to the
+Cabal package format and follows different design principles. Hpack packages
+are described in a file named @code{package.yaml}. Both @code{cabal2nix} and
+@code{stack} support @code{package.yaml} natively. For other build tools the
+@code{hpack} executable can be used to generate a @code{.cabal} file from
+@code{package.yaml}.")
+ (license license:expat)))
+
(define-public ghc-weigh
(package
(name "ghc-weigh")