aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-10-02 18:37:58 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-05 23:59:26 +0200
commit52f5114d016688fb143079056a64b8abfb319507 (patch)
tree8957eecec12400f91ff43ac01673e176120e6c95
parent5e6bf3e2da6934daeadc36afeb8e09f105754efe (diff)
downloadguix-52f5114d016688fb143079056a64b8abfb319507.tar
guix-52f5114d016688fb143079056a64b8abfb319507.tar.gz
gnu: Add ghc-raw-string-qq.
* gnu/packages/haskell.scm (ghc-raw-string-qq): New variable.
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9a5f7c9746..6b8a4ee3fc 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11044,6 +11044,31 @@ are described in a file named @code{package.yaml}. Both @code{cabal2nix} and
@code{package.yaml}.")
(license license:expat)))
+(define-public ghc-raw-strings-qq
+ (package
+ (name "ghc-raw-strings-qq")
+ (version "1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "raw-strings-qq/raw-strings-qq-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1lxy1wy3awf52968iy5y9r5z4qgnn2sxkdrh7js3m9gadb11w09f"))))
+ (build-system haskell-build-system)
+ (native-inputs `(("ghc-hunit" ,ghc-hunit)))
+ (home-page "https://github.com/23Skidoo/raw-strings-qq")
+ (synopsis "Raw string literals for Haskell")
+ (description
+ "This package provides a quasiquoter for raw string literals, i.e. string
+literals that don't recognise the standard escape sequences. Basically, they
+make your code more readable by freeing you from the responsibility to escape
+backslashes. They are useful when working with regular expressions,
+DOS/Windows paths and markup languages (such as XML).")
+ (license license:bsd-3)))
+
(define-public ghc-weigh
(package
(name "ghc-weigh")