aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-10-02 18:32:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-05 23:59:26 +0200
commit4fc161b9c60163f8353648a8e6e00d8229362ff4 (patch)
tree8d658b316a2df79adcdea5260ae7a82d5b9dcf11
parent44c6180b3fc76f5e015a1b7097eb7a3196210be8 (diff)
downloadguix-4fc161b9c60163f8353648a8e6e00d8229362ff4.tar
guix-4fc161b9c60163f8353648a8e6e00d8229362ff4.tar.gz
gnu: Add ghc-bzlib-conduit.
* gnu/packages/haskell.scm (ghc-bzlib-conduit): New variable.
-rw-r--r--gnu/packages/haskell.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 4ebaecbd86..d79329f686 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -10879,6 +10879,34 @@ functions.")
compression algorithm used in the @code{.xz} file format.")
(license license:bsd-3)))
+(define-public ghc-bzlib-conduit
+ (package
+ (name "ghc-bzlib-conduit")
+ (version "0.3.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/bzlib-conduit/"
+ "bzlib-conduit-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0fd2hnr782s7qgipazg2yxwia9qqhkvm9bcm90773c3zkxa13n23"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-bindings-dsl" ,ghc-bindings-dsl)
+ ("ghc-conduit" ,ghc-conduit)
+ ("ghc-data-default-class" ,ghc-data-default-class)
+ ("ghc-resourcet" ,ghc-resourcet)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("ghc-random" ,ghc-random)))
+ (home-page "https://github.com/snoyberg/bzlib-conduit")
+ (synopsis "Streaming compression/decompression via conduits")
+ (description
+ "This package provides Haskell bindings to bzlib and Conduit support for
+streaming compression and decompression.")
+ (license license:bsd-3)))
+
(define-public ghc-weigh
(package
(name "ghc-weigh")