aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-10-02 18:32:46 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-05 23:59:26 +0200
commit44c6180b3fc76f5e015a1b7097eb7a3196210be8 (patch)
tree562f21112848a83d2e730fe8156237369ceda251
parent38757d610eedad4dfa4030841132c028460b6c84 (diff)
downloadguix-44c6180b3fc76f5e015a1b7097eb7a3196210be8.tar
guix-44c6180b3fc76f5e015a1b7097eb7a3196210be8.tar.gz
gnu: Add ghc-lzma-conduit.
* gnu/packages/haskell.scm (ghc-lzma-conduit): New variable.
-rw-r--r--gnu/packages/haskell.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 41b1146040..4ebaecbd86 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -10848,6 +10848,37 @@ can use with C code to help write bindings to inline functions or macro
functions.")
(license license:bsd-3)))
+(define-public ghc-lzma-conduit
+ (package
+ (name "ghc-lzma-conduit")
+ (version "1.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/lzma-conduit/"
+ "lzma-conduit-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0hm72da7xk9l3zxjh274yg444vf405djxqbkf3q3p2qhicmxlmg9"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-conduit" ,ghc-conduit)
+ ("ghc-lzma" ,ghc-lzma)
+ ("ghc-resourcet" ,ghc-resourcet)))
+ (native-inputs
+ `(("ghc-base-compat" ,ghc-base-compat)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
+ ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-quickcheck" ,ghc-quickcheck)))
+ (home-page "https://github.com/alphaHeavy/lzma-conduit")
+ (synopsis "Conduit interface for lzma/xz compression")
+ (description
+ "This package provides a @code{Conduit} interface for the LZMA
+compression algorithm used in the @code{.xz} file format.")
+ (license license:bsd-3)))
+
(define-public ghc-weigh
(package
(name "ghc-weigh")