aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-10-02 18:32:40 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-05 23:59:26 +0200
commit36ec599e785ba3563ede377e05e8172c4323a2aa (patch)
tree4193176fcbc65577ba70fcd6e0a60d7ab4549c4c
parentd05ed20ef12e5c9520252f2da230c54f46de703d (diff)
downloadguix-36ec599e785ba3563ede377e05e8172c4323a2aa.tar
guix-36ec599e785ba3563ede377e05e8172c4323a2aa.tar.gz
gnu: Add ghc-lzma.
* gnu/packages/haskell.scm (ghc-lzma): New variable.
-rw-r--r--gnu/packages/haskell.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index a8d22a682a..3e10398966 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -10753,6 +10753,37 @@ permissions while atomically writing to a file.")
@code{Sources}, @code{Sinks}, and @code{Conduits}.")
(license license:bsd-3)))
+(define-public ghc-lzma
+ (package
+ (name "ghc-lzma")
+ (version "0.0.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/lzma/"
+ "lzma-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0i416gqi8j55nd1pqbkxvf3f6hn6fjys6gq98lkkxphva71j30xg"))))
+ (build-system haskell-build-system)
+ (arguments
+ '(#:tests? #f ; requires older versions of QuickCheck and tasty.
+ #:cabal-revision
+ ("3" "1sify6gnsalyp6dakfzi0mdy5jcz2kcp9jsdsgkmxd40nfzgd44m")))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
+ (home-page "https://github.com/hvr/lzma")
+ (synopsis "LZMA/XZ compression and decompression")
+ (description
+ "This package provides a pure interface for compressing and
+decompressing LZMA streams of data represented as lazy @code{ByteString}s. A
+monadic incremental interface is provided as well.")
+ (license license:bsd-3)))
+
(define-public ghc-weigh
(package
(name "ghc-weigh")