aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-10-02 18:32:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-05 23:59:26 +0200
commit320323141f697483277918f411ecc62a8a7ab85d (patch)
tree63b3c54dd68d76e26f07dc7900f46b4783ce3a2b
parenta933cbfb617d84d37e270b4dd89f2de92013834d (diff)
downloadguix-320323141f697483277918f411ecc62a8a7ab85d.tar
guix-320323141f697483277918f411ecc62a8a7ab85d.tar.gz
gnu: Add ghc-interpolate.
* gnu/packages/haskell.scm (ghc-interpolate): New variable.
-rw-r--r--gnu/packages/haskell.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index befb1baae5..8a33cbd6b2 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -10971,6 +10971,34 @@ based on a binomial heap.")
level asynchronous processing and some other utilities.")
(license license:expat)))
+(define-public ghc-interpolate
+ (package
+ (name "ghc-interpolate")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/interpolate/"
+ "interpolate-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1gkaj98yz363v38fv78sqby236mp8yqwqcilx7kr2b9z0w3204bf"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-haskell-src-meta" ,ghc-haskell-src-meta)))
+ (native-inputs
+ `(("ghc-base-compat" ,ghc-base-compat)
+ ("ghc-hspec" ,ghc-hspec)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-quickcheck-instances" ,ghc-quickcheck-instances)
+ ("ghc-text" ,ghc-text)
+ ("hspec-discover" ,hspec-discover)))
+ (home-page "https://github.com/sol/interpolate")
+ (synopsis "String interpolation library")
+ (description "This package provides a string interpolation library for
+Haskell.")
+ (license license:expat)))
+
(define-public ghc-weigh
(package
(name "ghc-weigh")