aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-09-29 11:18:54 +0100
committerChristopher Baines <mail@cbaines.net>2018-10-05 21:25:42 +0100
commit2c7cb711e938ff9e358ffb274ea2f96ae84fc1e9 (patch)
tree2b133ca9473c81c2155f039e579f94ebbe87c141
parent39ecb977d3e097ffe9c46390090bd197581ac072 (diff)
downloadguix-2c7cb711e938ff9e358ffb274ea2f96ae84fc1e9.tar
guix-2c7cb711e938ff9e358ffb274ea2f96ae84fc1e9.tar.gz
gnu: ruby-sass-spec: Fix spec expectation.
This fixes building ruby-sass with Ruby 2.5. * gnu/packages/ruby.scm (ruby-sass-spec)[arguments]: Add patch-test phase to fix the expectation of one of the tests. Also change the comment regarding the tests not being run.
-rw-r--r--gnu/packages/ruby.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index c039df1559..a0fe0c2e98 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5456,8 +5456,16 @@ strings or files.")
("ruby-diffy" ,ruby-diffy)
("ruby-terminfo" ,ruby-terminfo)))
(arguments
- ;; No Rakefile
- `(#:tests? #f))
+ `(;; This package contains tests for a sass implementation, and the to
+ ;; avoid any circular dependencies, the tests are not run here
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-test
+ (lambda _
+ (delete-file "spec/values/colors/alpha_hex-3.5/error")
+ (substitute* "spec/values/colors/alpha_hex-3.5/expected_output.css"
+ (("string") "color")))))))
(home-page "https://github.com/sass/sass-spec")
(synopsis "Test suite for Sass")
(description "Sass Spec is a test suite for Sass. Test cases are all in