aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-10-02 18:28:50 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-05 23:59:25 +0200
commit279c97dba8ceecab9d1c7a5c8b5503d1c2e605a3 (patch)
tree024251a9e97aa6870b39de4318a220ce8bed31be
parenta45c64701b5599bb527fd8cf2070174f9e866d3d (diff)
downloadguix-279c97dba8ceecab9d1c7a5c8b5503d1c2e605a3.tar
guix-279c97dba8ceecab9d1c7a5c8b5503d1c2e605a3.tar.gz
gnu: ghc-regex: Fix build.
* gnu/packages/haskell.scm (ghc-regex)[arguments]: Add build phase to relax version checks.
-rw-r--r--gnu/packages/haskell.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index a140985eba..c8e4523ebd 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3003,6 +3003,17 @@ Haskell library @code{regex-base}.")
(base32
"1sjkpkgv4phy5b5v2lr89x4vx4dh44pj0sbvlsp6n86w9v6v4jwb"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'relax-dependencies
+ (lambda _
+ (substitute* "regex.cabal"
+ (("base-compat.*>=.*0.6.*")
+ "base-compat >= 0.6\n")
+ (("template-haskell.*>=.*2.7.*")
+ "template-haskell >= 2.7\n"))
+ #t)))))
(inputs
`(("ghc-base-compat" ,ghc-base-compat)
("ghc-hashable" ,ghc-hashable)