aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2018-09-26 23:27:06 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2018-10-03 18:54:29 +0200
commit0c1fd6f8ade5c30e12985f7bd29ea4bf49559741 (patch)
treea7cf076c3f89a70ac95b3b02bf3da0c7598966ba
parentd406dcc046b140de616d3ea83a7591865c7eb5be (diff)
downloadguix-0c1fd6f8ade5c30e12985f7bd29ea4bf49559741.tar
guix-0c1fd6f8ade5c30e12985f7bd29ea4bf49559741.tar.gz
gnu: Add emacs-spaceline.
* gnu/packages/emacs.scm (emacs-spaceline): New variable.
-rw-r--r--gnu/packages/emacs.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index b9f3d678e0..1df3456e4a 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -12323,3 +12323,35 @@ a better-looking, more functional Emacs mode-line. A collection of predefined
themes comes with the package.")
(license license:gpl3+)))
+(define-public emacs-spaceline
+ (package
+ (name "emacs-spaceline")
+ (version "2.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/TheBB/spaceline.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1q8r95zfrh0vxna5ml2pq9b9f66clfqcl4d2qy2aizkvzyxg6skl"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("dash" ,emacs-dash)
+ ("powerline" ,emacs-powerline)
+ ("s" ,emacs-s)))
+ (home-page "https://github.com/TheBB/spaceline")
+ (synopsis "Powerline theme from Spacemacs")
+ (description "Spaceline provides Spacemacs' mode-line theme.
+This package provides features for three kinds of users.
+
+@itemize
+@item You just want to use the Spacemacs mode-line theme and forget about it.
+@item You want to use something similar to the Spacemacs mode-line theme, but
+with a handful of easy tweaks.
+@item You want an easy-to-use library for building your own mode-line from
+scratch, and you think the Spacemacs theme looks good.
+@end itemize")
+ (license license:gpl3+)))