aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2017-01-26 08:15:32 +0100
committerJohn Darrington <jmd@gnu.org>2017-01-26 19:45:22 +0100
commitfc12bc309909d1f28c55afef69c457f6711615ae (patch)
tree12e92ba2f8308c2e0fd171dfbd48db811b460171
parent9d58741a5037a6d153cdc5a9b0dfded1729bf08b (diff)
downloadguix-fc12bc309909d1f28c55afef69c457f6711615ae.tar
guix-fc12bc309909d1f28c55afef69c457f6711615ae.tar.gz
gnu: Add xcalc.
* gnu/packages/xorg.scm (xcalc): New variable.
-rw-r--r--gnu/packages/xorg.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index b67634731b..6b460ed02e 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2014,6 +2014,41 @@ the same way.")
legacy X clients.")
(license license:x11)))
+(define-public xcalc
+ (package
+ (name "xcalc")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://xorg/individual/app/" name "-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0s2gdkk3wxpmraqd05mxsy2895h2h22sbfk1q3jkc4nlmskga2xm"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after
+ 'configure 'mutate-makefile
+ (lambda _
+ (substitute* "Makefile"
+ (("^appdefaultdir = .*$")
+ (string-append "appdefaultdir = " %output
+ ,%app-defaults-dir "\n")))
+ #t)))))
+ (inputs
+ `(("libxaw" ,libxaw)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://www.x.org/wiki/")
+ (synopsis "Hand calculator for the X Window system")
+ (description "Xcalc is a scientific calculator desktop accessory that can
+emulate a TI-30 or an HP-10C.")
+ (license license:x11)))
+
(define-public xcb-proto
(package