aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-01-14 01:08:34 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-01-23 23:16:10 +0100
commitee6e780b2c2f2ba045b1d7d39e22d543e375dd0f (patch)
tree220c7e248f6ba73bc8a29a200e911f33c9383ff9
parent84b60a7cdfca1421a478894e279104a0c18a7c6d (diff)
downloadguix-ee6e780b2c2f2ba045b1d7d39e22d543e375dd0f.tar
guix-ee6e780b2c2f2ba045b1d7d39e22d543e375dd0f.tar.gz
gnu: Add compface.
* gnu/packages/mail.scm (compface): New variable.
-rw-r--r--gnu/packages/mail.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index dbbe629bca..bcb6473d23 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -90,7 +90,7 @@
#:select (gpl2 gpl2+ gpl3 gpl3+ lgpl2.1 lgpl2.1+ lgpl3+
non-copyleft (expat . license:expat) bsd-3
public-domain bsd-4 isc (openssl . license:openssl)
- bsd-2))
+ bsd-2 x11-style))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -733,6 +733,27 @@ provides an API for C language. It's the low-level API used by MailCore and
MailCore 2.")
(license (non-copyleft "file://COPYING"))))
+(define-public compface
+ (package
+ (name "compface")
+ (version "1.5.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://ftp.heanet.ie/mirrors/"
+ "ftp.xemacs.org/aux/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "09b89wg63hg502hsz592cd2h87wdprb1dq1k1y07n89hym2q56d6"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f))
+ (synopsis "Portrait image compressor")
+ (description "This packages takes your 48x48x1 portrait image and
+compresses it.")
+ (home-page "http://www.cs.indiana.edu/pub/faces/")
+ (license (x11-style "file://README"))))
+
(define-public claws-mail
(package
(name "claws-mail")