aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlo Zancanaro <carlo@zancanaro.id.au>2017-01-27 10:48:12 +1100
committerMarius Bakke <mbakke@fastmail.com>2017-01-27 01:28:36 +0100
commit95757d899907ee7352acdecf0962d665804ceccd (patch)
treef9cb24df769e3d576fe2657701390027f60d0911
parent70852355e6ccb948cffbaccdfe12ee9f33997e53 (diff)
downloadguix-95757d899907ee7352acdecf0962d665804ceccd.tar
guix-95757d899907ee7352acdecf0962d665804ceccd.tar.gz
gnu: kakoune: Move reproducibility substitution to source snippet.
* gnu/packages/text-editors.scm (kakoune)[arguments]: Move substitution to ... [source]: ... here. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/text-editors.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index cb4855860d..5b20d1d515 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -98,7 +98,15 @@ based command language.")
(commit commit)))
(sha256
(base32
- "19qs99l8r9p1vi5pxxx9an22fvi7xx40qw3jh2cnh2mbacawvdyb"))))
+ "19qs99l8r9p1vi5pxxx9an22fvi7xx40qw3jh2cnh2mbacawvdyb"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Kakoune uses 'gzip' to compress its manpages. Make sure
+ ;; timestamps are not preserved for reproducibility.
+ '(begin
+ (substitute* "src/Makefile"
+ (("gzip -f") "gzip -f --no-name"))
+ #t))))
(build-system gnu-build-system)
(arguments
`(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
@@ -117,10 +125,6 @@ based command language.")
(("if \\(m_shell.empty\\(\\)\\)" line)
(string-append "m_shell = \"" (which "sh")
"\";\n " line)))
- ;; Kakoune uses 'gzip' to compress its manpages. Make sure
- ;; timestamps are not preserved for reproducibility.
- (substitute* "src/Makefile"
- (("gzip -f") "gzip -f --no-name"))
#t))
(delete 'configure)
;; kakoune requires us to be in the src/ directory to build