aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-01-24 15:31:20 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-01-24 23:27:02 +0100
commit392f32665578bf83b2ed82fc2fb944b4bb4c6730 (patch)
tree51df960c59d71766ec5d23704ec345cd24e89bca
parentdb963aad3d7eaffb4633d1f54190f982502614dc (diff)
downloadguix-392f32665578bf83b2ed82fc2fb944b4bb4c6730.tar
guix-392f32665578bf83b2ed82fc2fb944b4bb4c6730.tar.gz
gnu: the-silver-searcher: Update to 1.0.2.
* gnu/packages/code.scm (the-silver-searcher): Update to 1.0.2. [source]: Use signed tarball from home-page. Remove file-name. [native-inputs]: Remove autoconf, automake, and libtool, as well as... [arguments]: ...the ‘autoconf’ phase since we're now building a release.
-rw-r--r--gnu/packages/code.scm23
1 files changed, 4 insertions, 19 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index f5aa7f4faf..061ec27b80 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -190,37 +190,22 @@ COCOMO model or user-provided parameters.")
(define-public the-silver-searcher
(package
(name "the-silver-searcher")
- (version "0.32.0")
+ (version "1.0.2")
(source (origin
(method url-fetch)
(uri (string-append
- "https://github.com/ggreer/the_silver_searcher/archive/"
+ "http://geoff.greer.fm/ag/releases/the_silver_searcher-"
version ".tar.gz"))
(sha256
(base32
- "1k543cjpignwvy8avhchz8pkqrqcgcryps36ycy8mz2w5rbhicn5"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ "0v54himv65w294l0k4lhdyc6kvpgijn8b9g5356479fzy7hphjkg"))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)))
(inputs
`(("pcre" ,pcre)
("xz" ,xz)
("zlib" ,zlib)))
- (arguments
- `(#:phases
- ;; There is no configure yet, so let's create it, but let configure and
- ;; make do the work in later phases.
- (alist-cons-before 'configure 'autoconf
- (lambda _
- (substitute* "build.sh"
- (("./configure") "true")
- (("make -j4") "true"))
- (zero? (system* "sh" "build.sh")))
- %standard-phases)))
(home-page "http://geoff.greer.fm/ag/")
(synopsis "Fast code searching tool")
(description