aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-23 16:23:12 -0500
committerLeo Famulari <leo@famulari.name>2017-01-23 17:23:04 -0500
commit195279529c9116393b4adadf85d8922095e00486 (patch)
tree68de8c69eded781a26cd39c25aad9506d2189ee1
parent7ba024922377c60d259725db79840f976979b790 (diff)
downloadguix-195279529c9116393b4adadf85d8922095e00486.tar
guix-195279529c9116393b4adadf85d8922095e00486.tar.gz
gnu: sendmail: Don't replace 'sh' reference with 'bash'.
* gnu/packages/mail.scm (sendmail)[arguments]: Use (which "sh") instead of (which "bash") in 'replace-/bin/sh' phase.
-rw-r--r--gnu/packages/mail.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index bcb6473d23..2318ae9b64 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1557,10 +1557,10 @@ powerful user customization features.")
"contrib/mmuegel" "devtools/bin/configure.sh")
(find-files "." ".*\\.m4")
(find-files "." ".*\\.cf"))
- (("/bin/sh") (which "bash")))
+ (("/bin/sh") (which "sh")))
(substitute* "devtools/bin/Build"
- (("SHELL=/bin/sh") (string-append "SHELL=" (which "bash"))))
+ (("SHELL=/bin/sh") (string-append "SHELL=" (which "sh"))))
#t))
(replace 'configure
(lambda _