aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-21 11:09:36 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-21 11:21:14 +0200
commitcf867de06124578cd66e1d54b44b7f2906a503d5 (patch)
tree47b69fcd03bd4a1f42793c5f00b1e650719da35d
parent755fc873058e559e249d2433f5d19fee857b8720 (diff)
downloadguix-cf867de06124578cd66e1d54b44b7f2906a503d5.tar
guix-cf867de06124578cd66e1d54b44b7f2906a503d5.tar.gz
gnu: perl-file-remove: Update to 1.58.
* gnu/packages/perl.scm (perl-file-remove): Update to 1.58. [description]: Texify the description.
-rw-r--r--gnu/packages/perl.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 5067a68c80..6fc7d49e18 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3559,7 +3559,7 @@ the input record separator string on a per file basis.")
(define-public perl-file-remove
(package
(name "perl-file-remove")
- (version "1.57")
+ (version "1.58")
(source
(origin
(method url-fetch)
@@ -3567,14 +3567,16 @@ the input record separator string on a per file basis.")
"File-Remove-" version ".tar.gz"))
(sha256
(base32
- "1b814lw181kkqh6c1n4p2zlzzsq6ic5pfpr831nphf2w2rhcvgmk"))))
+ "1n6h5w3sp2bs4cfrifdx2z15cfpb4r536179mx1a12xbmj1yrxl1"))))
(build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
(home-page "https://metacpan.org/release/File-Remove")
(synopsis "Remove files and directories in Perl")
- (description "File::Remove::remove removes files and directories. It acts
-like /bin/rm, for the most part. Although \"unlink\" can be given a list of
-files, it will not remove directories; this module remedies that. It also
-accepts wildcards, * and ?, as arguments for file names.")
+ (description "@code{File::Remove::remove} removes files and directories.
+It acts like @code{/bin/rm}, for the most part. Although @code{unlink} can be
+given a list of files, it will not remove directories; this module remedies
+that. It also accepts wildcards, * and ?, as arguments for file names.")
(license (package-license perl))))
(define-public perl-file-sharedir