aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2019-01-22 16:12:08 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2019-01-22 16:12:08 +0100
commitc63d7b7975fd15066c056d8a8715d9ce1b10389e (patch)
tree9e7daa1a786938c28cc273c8817947bbd0b908c3
parent0a59cc6e8590fc6c2c56dc35aca5c4b558d67901 (diff)
downloadguix-c63d7b7975fd15066c056d8a8715d9ce1b10389e.tar
guix-c63d7b7975fd15066c056d8a8715d9ce1b10389e.tar.gz
gnu: Add genext2fs.
* gnu/packages/linux.scm (genext2fs): New variable.
-rw-r--r--gnu/packages/linux.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 961d516858..5f3d4707aa 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5038,3 +5038,25 @@ file systems.")
;; The library "libhandle" and the headers in "xfslibs-dev" are
;; licensed under lgpl2.1. the other stuff is licensed under gpl2.
(license (list license:gpl2 license:lgpl2.1))))
+
+(define-public genext2fs
+ (package
+ (name "genext2fs")
+ (version "1.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jeremie-koenig/genext2fs.git")
+ (commit (string-append "genext2fs-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1r0n74pyypv63qfqqpvx75dwijcsvcrvqrlv8sldbhv0nwr1gk53"))))
+ (build-system gnu-build-system)
+ (home-page "https://github.com/jeremie-koenig/genext2fs")
+ (synopsis "Generate ext2 filesystem as a normal user")
+ (description "This package provides a program to general an ext2
+filesystem as a normal (non-root) user. It does not require you to mount
+the image file to copy files on it, nor does it require that you become
+the superuser to make device nodes.")
+ (license license:gpl2)))