aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-22 12:16:39 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-22 12:59:14 +0200
commit354d27e5dcf6b946e1ab70d534c8cbde088d3b73 (patch)
tree353b91e79ca5bc7f65403c4964e06bedb1821945
parente2227b6adae0abdb9aa5b9995ccf89d38b2314d7 (diff)
downloadguix-354d27e5dcf6b946e1ab70d534c8cbde088d3b73.tar
guix-354d27e5dcf6b946e1ab70d534c8cbde088d3b73.tar.gz
gnu: python-websocket-client: Update to 0.54.0.
* gnu/packages/python-web.scm (python-websocket-client): Update to 0.54.0. [properties]: New field. (python2-websocket-client)[native-inputs]: Add python2-backport-ssl-match-hostname.
-rw-r--r--gnu/packages/python-web.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index af0595b36d..cee4973086 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
-;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2016, 2017 Danny Milosavljevic <dannym+a@scratchpost.org>
;;; Copyright © 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
@@ -1218,14 +1218,14 @@ verification of the SSL peer.")
(define-public python-websocket-client
(package
(name "python-websocket-client")
- (version "0.37.0")
+ (version "0.54.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "websocket_client" version))
(sha256
(base32
- "0h9glp1jll3z76ly3kg08aqgxqk0a68p4zi9yn50353bh5nj92v7"))))
+ "0j88zmikaypf38lvpkf4aaxrjp9j07dmy5ghj7kli0fv3p4n45g5"))))
(build-system python-build-system)
(propagated-inputs
`(("python-six" ,python-six)))
@@ -1233,10 +1233,18 @@ verification of the SSL peer.")
(synopsis "WebSocket client for Python")
(description "The Websocket-client module provides the low level APIs for
WebSocket usage in Python programs.")
+ (properties `((python2-variant . ,(delay python2-websocket-client))))
(license license:lgpl2.1+)))
(define-public python2-websocket-client
- (package-with-python2 python-websocket-client))
+ (let ((base (package-with-python2
+ (strip-python2-variant python-websocket-client))))
+ (package
+ (inherit base)
+ (native-inputs
+ `(("python2-backport-ssl-match-hostname"
+ ,python2-backport-ssl-match-hostname)
+ ,@(package-native-inputs base))))))
(define-public python-requests
(package