aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-11-29 01:05:47 -0500
committerLeo Famulari <leo@famulari.name>2017-11-29 01:12:18 -0500
commit3519f2841d459271600bd1a41f0f3c6eb8b009aa (patch)
tree5fb64dbd4d0103f21c0167d016e5ba4a049ee661
parentd2bdee8a69d3316c91fab68fe0cfb2a533db9ce6 (diff)
downloadguix-3519f2841d459271600bd1a41f0f3c6eb8b009aa.tar
guix-3519f2841d459271600bd1a41f0f3c6eb8b009aa.tar.gz
gnu: libtorrent-rasterbar: Update to 1.1.4.
* gnu/packages/bittorrent.scm (libtorrent-rasterbar): Update to 1.1.4. [source]: Remove 'libtorrent-rasterbar-boost-compat.patch'. * gnu/packages/patches/libtorrent-rasterbar-boost-compat.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/bittorrent.scm6
-rw-r--r--gnu/packages/patches/libtorrent-rasterbar-boost-compat.patch27
3 files changed, 2 insertions, 32 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 13acb6797c..5ea975c4f4 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -835,7 +835,6 @@ dist_patch_DATA = \
%D%/packages/patches/libtiff-tiffycbcrtorgb-integer-overflow.patch \
%D%/packages/patches/libtiff-tiffycbcrtorgbinit-integer-overflow.patch \
%D%/packages/patches/libtirpc-CVE-2017-8779.patch \
- %D%/packages/patches/libtorrent-rasterbar-boost-compat.patch \
%D%/packages/patches/libtool-skip-tests2.patch \
%D%/packages/patches/libunistring-gnulib-multi-core.patch \
%D%/packages/patches/libusb-0.1-disable-tests.patch \
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index cad8b667bb..90ce33eafd 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -382,7 +382,7 @@ and will take advantage of multiple processor cores where possible.")
(define-public libtorrent-rasterbar
(package
(name "libtorrent-rasterbar")
- (version "1.1.2")
+ (version "1.1.4")
(source (origin
(method url-fetch)
(uri
@@ -390,11 +390,9 @@ and will take advantage of multiple processor cores where possible.")
"https://github.com/arvidn/libtorrent/releases/download/libtorrent-"
(string-join (string-split version #\.) "_")
"/libtorrent-rasterbar-" version ".tar.gz"))
- (patches
- (search-patches "libtorrent-rasterbar-boost-compat.patch"))
(sha256
(base32
- "16im9qsmfrmmkhfjpij9739nqpn4s6wgc9cikdxbcyshfhimzra5"))))
+ "19pb9sn71m4gnnrm3f1kxic63km9s3vx2mj7rznzfv9sh1kj7x6c"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
diff --git a/gnu/packages/patches/libtorrent-rasterbar-boost-compat.patch b/gnu/packages/patches/libtorrent-rasterbar-boost-compat.patch
deleted file mode 100644
index 85bea76efe..0000000000
--- a/gnu/packages/patches/libtorrent-rasterbar-boost-compat.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Fix compatibility with Boost 1.63.
-
-Patch copied from upstream source repository:
-
-https://github.com/arvidn/libtorrent/commit/6d2d736cecce0af274dd651dd1f562716b625d92
-
-From 6d2d736cecce0af274dd651dd1f562716b625d92 Mon Sep 17 00:00:00 2001
-From: arvidn <arvid@cs.umu.se>
-Date: Sun, 12 Mar 2017 13:03:26 -0400
-Subject: [PATCH] fix test_ssl.cpp build with newer versions of boost
-
----
- test/test_ssl.cpp | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/test/test_ssl.cpp b/test/test_ssl.cpp
-index 01c5bc7..2903332 100644
---- a/test/test_ssl.cpp
-+++ b/test/test_ssl.cpp
-@@ -51,7 +51,6 @@ POSSIBILITY OF SUCH DAMAGE.
- #include <boost/asio/connect.hpp>
-
- #ifdef TORRENT_USE_OPENSSL
--#include <boost/asio/ssl/error.hpp> // for asio::error::get_ssl_category()
- #include <boost/asio/ssl.hpp>
-
- #include "libtorrent/aux_/disable_warnings_pop.hpp"