aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-11-09 20:42:56 +0000
committerChristopher Baines <mail@cbaines.net>2019-01-22 18:19:49 +0000
commit31314f39e91ef0940fc7bb0474d2333a5f7af033 (patch)
treed11fe3aa810548c9f414717306192d3662d1e10f
parent24dedc2b47137811441979206d4a6accb14468fb (diff)
downloadguix-31314f39e91ef0940fc7bb0474d2333a5f7af033.tar
guix-31314f39e91ef0940fc7bb0474d2333a5f7af033.tar.gz
Add python-drf-nested-routers
-rw-r--r--gnu/packages/python-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index cee4973086..92473c4ab4 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2922,3 +2922,31 @@ underlies Mozilla Persona.")
"This is a Python library for interacting with the Firefox Accounts
ecosystem.")
(license license:mpl2.0)))
+
+(define-public python-drf-nested-routers
+ (package
+ (name "python-drf-nested-routers")
+ (version "0.91")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "drf-nested-routers" version))
+ (sha256
+ (base32
+ "0d2hb2jdm8s8pfdmkqr8cay1n4prx0l51mypmypjqy2wq6mw7ra6"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-django" ,python-django)
+ ("python-djangorestframework"
+ ,python-djangorestframework)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-django" ,python-pytest-django)))
+ (home-page
+ "https://github.com/alanjds/drf-nested-routers")
+ (synopsis
+ "Nested resources for the Django Rest Framework")
+ (description
+ "Nested resources for the Django Rest Framework")
+ (license #f)))