aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-22 11:19:53 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-22 11:47:40 +0200
commit2782bd51f48e3f5a86c53e440b8698a5960f0323 (patch)
treeeb9672d28e54ad0cddbe291a3354ae89db65ea24
parentdb58e326e5d7cee9e8e4dec3e2496c82c03adefc (diff)
downloadguix-2782bd51f48e3f5a86c53e440b8698a5960f0323.tar
guix-2782bd51f48e3f5a86c53e440b8698a5960f0323.tar.gz
gnu: python-virtualenv: Update to 16.1.0.
* gnu/packages/python-xyz.scm (python-virtualenv): Update to 16.1.0. [arguments]: Move custom 'check phase to custom 'disable-failing-test phase and re-instate standard 'check phase.
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a6e6982f6b..a7b89770c9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1997,25 +1997,25 @@ e.g. filters, callbacks and errbacks can all be promises.")
(define-public python-virtualenv
(package
(name "python-virtualenv")
- (version "15.0.3")
+ (version "16.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "virtualenv" version))
(sha256
(base32
- "07cbajzk8l05k5zhlw0b9wbf2is65bl9v6zrn2a0iyn57w6pd73d"))))
+ "0242cg3hdq3qdvx5flyrki8lpwlgwf5k45c21ks5049fv7ygm6gq"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (replace 'check
+ (add-before 'check 'disable-failing-test
(lambda _
;; Disable failing test. See upstream bug report
;; https://github.com/pypa/virtualenv/issues/957
(substitute* "tests/test_virtualenv.py"
(("skipif.*") "skipif(True, reason=\"Guix\")\n"))
- (zero? (system* "py.test")))))))
+ #t)))))
(native-inputs
`(("python-mock" ,python-mock)
("python-pytest" ,python-pytest)))