aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-21 10:45:17 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-21 11:21:12 +0200
commit26eb9260f9236852263d8720419977afc7bcb6d8 (patch)
tree19992c11f2893693f2bc143e4f871ff1f5689905
parente9dfa4d839cf21b8519724ef53df4862a74c67ec (diff)
downloadguix-26eb9260f9236852263d8720419977afc7bcb6d8.tar
guix-26eb9260f9236852263d8720419977afc7bcb6d8.tar.gz
gnu: Add perl-test-more-utf8.
* gnu/packages/perl-check.scm (perl-test-more-utf8): New variable.
-rw-r--r--gnu/packages/perl-check.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index ee832ccf94..c1edf48f06 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -788,6 +788,28 @@ set_relative_time, set_absolute_time or set_fixed_time to alter future calls
to gmtime,time or localtime.")
(license perl-license)))
+(define-public perl-test-more-utf8
+ (package
+ (name "perl-test-more-utf8")
+ (version "0.05")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MO/MONS/Test-More-UTF8-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "016fs77lmw8xxrcnapvp6wq4hjwgsdfi3l9ylpxgxkcpdarw9wdr"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Test-More-UTF8")
+ (synopsis "Enhance Test::More for UTF8-based projects")
+ (description "@code{Test::More::UTF8} is a simple extension for the widely
+used @code{Test::More} module. By default, it will do a @code{binmode ':utf8'}
+on all of @code{Test::Builder}'s output handles thus enabling the easy use
+flagged strings without warnings like \"Wide character in print @dots{}\"")
+ (license perl-license)))
+
(define-public perl-test-most
(package
(name "perl-test-most")