aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-17 12:55:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-22 15:10:59 +0100
commit0845999a5ece26eb382ea21f6d5da5caa649c8c6 (patch)
tree3c63300a2ccbf46c0b2976fda54951ef1e6e3c23
parent11627ca550612843c30944f5bb8cfb74f77ffa3e (diff)
downloadguix-0845999a5ece26eb382ea21f6d5da5caa649c8c6.tar
guix-0845999a5ece26eb382ea21f6d5da5caa649c8c6.tar.gz
gnu: Add glibc-locales variants for older versions of glibc.
* gnu/packages/base.scm (make-glibc-locales, make-glibc-utf8-locales): New procedures. (glibc-locales): Express in terms of make-glibc-locales. (glibc-utf8-locales): Express in terms of make-glibc-utf8-locales. (glibc-locales-2.27, glibc-utf8-locales-2.27): New variables.
-rw-r--r--gnu/packages/base.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index e79d2a987b..cf86f06588 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -13,7 +13,7 @@
;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -975,7 +975,7 @@ with the Linux kernel.")
(("/bin/pwd") "pwd"))
#t))))))))
-(define-public glibc-locales
+(define-public (make-glibc-locales glibc)
(package
(inherit glibc)
(name "glibc-locales")
@@ -1010,7 +1010,7 @@ the 'share/locale' sub-directory of this package.")
,(version-major+minor
(package-version glibc)))))))))))
-(define-public glibc-utf8-locales
+(define-public (make-glibc-utf8-locales glibc)
(package
(name "glibc-utf8-locales")
(version (package-version glibc))
@@ -1060,6 +1060,18 @@ test environments.")
(home-page (package-home-page glibc))
(license (package-license glibc))))
+(define-public glibc-locales
+ (make-glibc-locales glibc))
+(define-public glibc-utf8-locales
+ (make-glibc-utf8-locales glibc))
+
+(define-public glibc-locales-2.27
+ (package (inherit (make-glibc-locales glibc-2.27))
+ (name "glibc-locales-2.27")))
+(define-public glibc-utf8-locales-2.27
+ (package (inherit (make-glibc-utf8-locales glibc-2.27))
+ (name "glibc-utf8-locales-2.27")))
+
(define-public which
(package
(name "which")