aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-04-29 20:51:37 -0400
committerTimothy Sample <samplet@ngyro.com>2019-04-29 23:04:35 -0400
commit9aa470e912bff3af0f5803797c8c88a6cd6bdb8b (patch)
tree15568f8497d40bec3df2fda63982e5d5167cfc34
parent5aafccebbed7c9474a021623e6d8823cffde95b5 (diff)
downloadguix-9aa470e912bff3af0f5803797c8c88a6cd6bdb8b.tar
guix-9aa470e912bff3af0f5803797c8c88a6cd6bdb8b.tar.gz
gnu: awesome: Use absolute paths in session file.
* gnu/packages/wm.scm (awesome)[arguments]: Add a phase to patch the session '.desktop' file to use the absolute path of the 'awesome' binary.
-rw-r--r--gnu/packages/wm.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index c7dea8ba9b..b878df2895 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2018 Pierre-Antoine Rouby <contact@parouby.fr>
;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2019 Timothy Sample <samplet@ngyro.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -793,6 +794,13 @@ experience.")
;; There aren't any tests, so just make sure the binary
;; gets built and can be run successfully.
(invoke "../build/awesome" "-v")))
+ (add-after 'install 'patch-session-file
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (awesome (string-append out "/bin/awesome")))
+ (substitute* (string-append out "/share/xsessions/awesome.desktop")
+ (("Exec=awesome") (string-append "Exec=" awesome)))
+ #t)))
(add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((awesome (assoc-ref outputs "out"))