aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-04-30 10:23:02 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-04-30 10:28:21 +0200
commit6215132155e1a36629fdc5001edbf9dd53ead93f (patch)
treeb7554faf4753488a72d504cda6b99a4b43e65290
parentaa7cdc57dc28673dedfc6ec210974aaa0099a419 (diff)
downloadguix-6215132155e1a36629fdc5001edbf9dd53ead93f.tar
guix-6215132155e1a36629fdc5001edbf9dd53ead93f.tar.gz
gnu: ocaml-camomile: Install data in the store.
* gnu/packages/ocaml.scm (ocaml-camomile)[arguments]: Fix configuration to look for and install data in the store.
-rw-r--r--gnu/packages/ocaml.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index affdff2a67..108907ca70 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2954,7 +2954,14 @@ the plugins facilitate extensibility, and the frontends serve as entry points.")
`(("camlp4" ,camlp4)))
(arguments
`(#:build-flags (list "--profile" "realease")
- #:tests? #f))
+ #:test-target "camomile-test"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'fix-usr-share
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* '("Camomile/jbuild" "configure.ml")
+ (("/usr/share") (string-append (assoc-ref outputs "out") "/share")))
+ #t)))))
(synopsis "Comprehensive Unicode library")
(description "Camomile is a Unicode library for OCaml. Camomile provides
Unicode character type, UTF-8, UTF-16, UTF-32 strings, conversion to/from about