aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-04-29 20:51:37 -0400
committerTimothy Sample <samplet@ngyro.com>2019-04-29 20:54:43 -0400
commit4ec42524dd51aaaf9cd45520c0fdc89d6579d9e3 (patch)
treecd6cd249818385bef9aa2ef9e265fe0d6061ff9b
parente8c6e771c199c02b748eb66d3a03c46d2a32ca29 (diff)
downloadguix-4ec42524dd51aaaf9cd45520c0fdc89d6579d9e3.tar
guix-4ec42524dd51aaaf9cd45520c0fdc89d6579d9e3.tar.gz
gnu: awesome: Use absolute paths in session file.
* gnu/packages/wm.scm (awesome)[arguments]: Add a phase to patch the session '.desktop' file to use the absolute path of the 'awesome' binary.
-rw-r--r--gnu/packages/wm.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 0f1b0f35e9..6d650a834a 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2018 Pierre-Antoine Rouby <contact@parouby.fr>
;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2019 Timothy Sample <samplet@ngyro.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -823,6 +824,13 @@ experience.")
;; There aren't any tests, so just make sure the binary
;; gets built and can be run successfully.
(invoke "../build/awesome" "-v")))
+ (add-after 'install 'patch-session-file
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (awesome (string-append out "/bin/awesome")))
+ (substitute* (string-append out "/share/xsessions/awesome.desktop")
+ (("Exec=awesome") (string-append "Exec=" awesome)))
+ #t)))
(add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((awesome (assoc-ref outputs "out"))