aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-01 18:27:33 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-01 22:15:02 +0200
commit03c59a25250df33459a91add0e3f10abcba1f8d9 (patch)
tree0ac1231234b999488759914d85d14c0a190e31de
parenta0d44bb09f0d1b5819ccca51b75b6870ae485225 (diff)
downloadguix-03c59a25250df33459a91add0e3f10abcba1f8d9.tar
guix-03c59a25250df33459a91add0e3f10abcba1f8d9.tar.gz
gnu: vte-ng: Update to 0.56.2.a.
* gnu/packages/gnome.scm (vte-ng): Update to 0.56.2.a. [native-inputs]: Add GCC-7. [arguments]: Add GCC7 workaround.
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f19b1836d3..d33af15a29 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2324,7 +2324,7 @@ editors, IDEs, etc.")
(package
(inherit vte)
(name "vte-ng")
- (version "0.54.2.a")
+ (version "0.56.2.a")
(home-page "https://github.com/thestinger/vte-ng")
(source (origin
(method git-fetch)
@@ -2332,10 +2332,11 @@ editors, IDEs, etc.")
(file-name (git-file-name name version))
(sha256
(base32
- "1r7d9m07cpdr4f7rw3yx33hmp4jmsk0dn5byq5wgksb2qjbc4ags"))))
+ "1lmba6i0abifmvvfb1q63ql6zh6d38148kp6skmkggiib2hi5dki"))))
(native-inputs
`(("gtk-doc" ,gtk-doc)
("gperf" ,gperf)
+ ("gcc" ,gcc-7)
("autoconf" ,autoconf)
("automake" ,automake)
("libtool" ,libtool)
@@ -2344,6 +2345,9 @@ editors, IDEs, etc.")
`(#:phases (modify-phases %standard-phases
(replace 'bootstrap
(lambda _
+ ;; Work around GCC7 problem: <https://bugs.gnu.org/30756>.
+ (for-each unsetenv '("C_INCLUDE_PATH" "CPLUS_INCLUDE_PATH"))
+
(setenv "NOCONFIGURE" "true")
(invoke "sh" "autogen.sh"))))))
(synopsis "Enhanced VTE terminal widget")