aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2016-02-08 17:18:36 +0300
committerAlex Kost <alezost@gmail.com>2016-02-10 01:34:17 +0300
commitb654de6da15e8be88b46d184cd775e3743b71648 (patch)
tree17399bc6e2653ae57bda21680fb6e8d7b28ac35f
parent3db5ed11dac28ee1dc2b4ec140e8863cfcabea82 (diff)
downloadguix-b654de6da15e8be88b46d184cd775e3743b71648.tar
guix-b654de6da15e8be88b46d184cd775e3743b71648.tar.gz
gnu: Add emacs-async.
* gnu/packages/emacs.scm (emacs-async): New variable.
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 00aa885bdb..aa308cbd41 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -921,6 +921,27 @@ like. It can be linked with various Emacs mail clients (Message and Mail
mode, Rmail, Gnus, MH-E, and VM). BBDB is fully customizable.")
(license license:gpl3+)))
+(define-public emacs-async
+ (package
+ (name "emacs-async")
+ (version "1.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://elpa.gnu.org/packages/async-"
+ version ".tar"))
+ (sha256
+ (base32
+ "17psvz75n42x33my967wkgi7r0blx46n3jdv510j0z5jswv66039"))))
+ (build-system emacs-build-system)
+ (home-page "http://elpa.gnu.org/packages/async.html")
+ (synopsis "Asynchronous processing in Emacs")
+ (description
+ "This package provides the ability to call asynchronous functions and
+processes. For example, it can be used to run dired commands (for copying,
+moving, etc.) asynchronously using @code{dired-async-mode}. Also it is used
+as a library for other Emacs packages.")
+ (license license:gpl3+)))
+
(define-public emacs-auctex
(package
(name "emacs-auctex")